Debugger

The FreeBSD base system currently has GDB 6.1.1, and a policy of not allowing GPLv3 code. That leaves us with GDB 6.6 as the most recent GDB version we can take; the longer term roadmap is going to require a migration to lldb or another debugger.

Import GDB6.6 into FreeBSD base

LLDB

Compiler

Diagnostic Tools

Valgrind

Google-perftools

jemalloc

DTrace

Random probes with incorrect argument types

EdMaste/DeveloperTools (last edited 2012-10-31 18:13:02 by EdMaste)