GVINUM(8) FreeBSD System Manager's Manual GVINUM(8)
- gvinum -- Logical Volume Manager control program
- gvinum [command] [-options]
- checkparity [-f] plex
- Check the parity blocks of a RAID-5 plex. The parity check will start at the beginning of the plex if the -f flag is specified, or otherwise at the location of the parity check pointer, the first location at which plex's parity is incorrect. All subdisks in the plex must be up for a parity check.
- Create a volume as described in description-file. If no description-file provided, opens an editor and provides the cur- rent gvinum configuration for editing.
- List information about the relevant object(s). The -r flag pro- vides recursive display, showing each object's subordinate objects in proper relation. The -v and -V flags provide progres- sively more detailed output.
- Move the subdisk(s) to the specified drive. The -f flag is required, as all data on the indicated subdisk(s) will be destroyed as part of the move. If the subdisk(s) form part of a RAID-5 plex, the disk(s) will need to be set to the 'up' state and the plex will require a rebuildparity command; if the subdisk(s) form part of a plex that is mirrored with other plexes, the plex will require restarting and will sync once restarted. Moving more than one subdisk in a RAID-5 plex or subdisks from both sides of a mirrored plex volume will destroy data. Note that parity rebuilds and syncing must be started manually after a move.
- Write a copy of the current configuration to standard output.
- would be done by entering the EOF character.
- Change the name of the specified object. The -r flag will recur- sively rename subordinate objects. Note that device nodes will not be renamed until gvinum is restarted.
- Rebuild the parity blocks of a RAID-5 plex. The parity rebuild will start at the beginning of the plex if the -f flag is speci- fied, or otherwise at the location of the parity check pointer. All subdisks in the plex must be up for a parity check.
- Remove an object and, if -r is specified, its subordinate objects.
- Save gvinum configuration to disk after configuration failures.
- Set state without influencing other objects, for diagnostic pur- poses only. The -f flag forces state changes regardless of whether they are legal.
- Allow the system to access the objects. The -S flag is currently ignored.
- The gvinum utility communicates with the kernel component of the GVinum logical volume manager. It is designed either for interactive use, when started without command line arguments, or to execute a single command if the command is supplied on the command line. In interactive mode, gvinum maintains a command line history.
- gvinum commands may be followed by an option.
-f The -f (force) option overrides safety checks. It should be
- used with extreme caution. This option is required in order to use the move command.
-r The -r (recursive) option applies the command recursively to
- subordinate objects. For example, in conjunction with the lv command, the -r option will also show information about the plexes and subdisks belonging to the volume. It is also used by the rename command to indicate that subordinate objects such as subdisks should be renamed to match the object(s) specified and by the rm command to delete plexes belonging to a volume and so on.
-v The -v (verbose) option provides more detailed output.
-V The -V (very verbose) option provides even more detailed out-
- put than -v.
- /dev/gvinum directory with device nodes for gvinum objects /dev/gvinum/plex directory containing device nodes for gvinum plexes /dev/gvinum/sd directory containing device nodes for gvinum subdisks
- EDITOR The name of the editor to use for editing configuration files, by
- default vi.
- vinum(4), vinum(8), geom(8)
- The gvinum utility first appeared in FreeBSD 5.3. The vinum utility, on which gvinum is based, was written by Greg Lehey. gvinum was written by Lukas Ertl. The move and rename commands and docu- mentation were added by Chris Jones through the 2005 Google Summer of Code program.
- gvinum(8) does not rename devices in /dev/gvinum until reloaded. The -S initsize flag to start is ignored. The stop command does not work. Moving subdisks that are not part of a mirrored or RAID-5 volume will destroy data. It is perhaps a bug to permit this. Plexes in which subdisks have been moved do not automatically sync or rebuild parity. This may leave data unprotected and is perhaps unwise. gvinum(8) does not yet fully implement all functions found in vinum(4). Specifically, the following commands from vinum(4) are not supported: attach plex volume [rename] attach subdisk plex [offset] [rename]
- Attach a plex to a volume, or a subdisk to a plex.
- Create a concatenated volume from the specified drives.
- Set debugging flags.
- Detach a plex or subdisk from the volume or plex to which it is attached.
- List the configuration information stored on the specified drives, or all drives in the system if no drive names are speci- fied.
- List information about volume manager state.
- Create a volume label.
- Create a mirrored volume from the specified drives.
- Reset the complete gvinum configuration.
- Reset statistics counters for the specified objects, or for all objects if none are specified.
- Set daemon configuration.
- Terminate access to the objects, or stop gvinum if no parameters are specified.
- Create a striped volume from the specified drives.
FreeBSD 5.4 July 24, 2005 FreeBSD 5.4