Package Building on MIPS

MarkLinimon has begun experimenting with package building on the mips architecture. Here are some notes.

Packages known to fail

portname

package

comments

devel/binutils

binutils-2.22

*** ld does not support target mips64-portbld-freebsd10.0 *** see ld/configure.tgt for supported targets

devel/cmake

cmake-2.8.8

c++: Internal error: Killed: 9 (program cc1plus)

devel/libffi

libffi-3.0.9

libffi has not been ported to mips64-portbld-freebsd10.0 (NB: affects lang/ruby19)

lang/python27

python27-2.7.3_2

usable -- just mtree (can be easily fixed)

lang/mpd

mpd-5.6

see gonzo for patches to build it

mail/dma

dma-v0.7_1,1

aliases_parse.c:84: warning: redundant redeclaration of 'yyparse'

mail/postfix

postfix-2.9.3,1

postfix: warning: valid_hostname: empty hostname

mail/sendmail

sendmail-8.14.5

your system does not support sysvipc

Packages known to succeed

autoconf-2.69 automake-wrapper-20101119 bash-4.2.28 bison-2.5,1 ccache-3.1.7_1 cscope-15.8 ctags-5.8 cvsps-2.1 db42-4.2.52_5 expat-2.0.1_2 expect-5.43.0_3 fastest_cvsup-0.3.0 ganglia-monitor-core-3.1.7_4 gawk-4.0.1 gdbm-1.9.1 gettext-0.18.1.1 git-1.7.10.3 gmake-3.82 gmp-5.0.5 help2man-1.40.10 isc-dhcp41-client-4.1.e_1,2 isc-dhcp41-server-4.1.e_4,2 iso-codes-3.35 libconfuse-2.7 libevent-1.4.14b_2 libiconv-1.14 libsigsegv-2.10 libtool-2.4.2 lynx-2.8.7.2,1 m4-1.4.16,1 mpfr-3.1.0_3 openldap-client-2.3.43 openldap-client-2.4.31_1 openssh-portable-5.8.p2_3,1 p5-Error-0.17018 p5-Locale-gettext-1.05_3 patch-2.6.1_1 pcre-8.30_2 pkg-config-0.25_1 portaudit-0.6.0 portlint-2.13.10_1 portmaster-3.12.1 poudriere-1.5.2 procmail-3.22_7 python-2.7,2 ruby-1.8.7.358,1 rsync-3.0.9 screen-4.0.3_13 socat-1.7.2.1 sqlite3-3.7.12.1 squid-2.7.9_1 subversion-1.7.5 sudo-1.8.5.p2 tcl-8.4.19_3,1 tmux-1.6 zsh-4.3.17_3

apr-ipv6-devrandom-gdbm-db42-1.4.5.1.3.12_1 autoconf-wrapper-20101119 automake-1.12 perl-5.12.4_4 pkg-1.0.b16 png-1.4.11

PackagesOnMIPS (last edited 2012-08-28 05:29:51 by MarkLinimon)