Differences between revisions 64 and 65
Revision 64 as of 2021-10-15T05:03:46+0000
Size: 15126
Editor: GrahamPerrin
Comment: Dereference the blog for now. See the 2021-06-30T16:18:05+0000 comment from Warner Losh.
Revision 65 as of 2021-10-15T06:41:51+0000
Size: 14146
Editor: GrahamPerrin
Comment: Encouraging use of sysrc (avoiding misconfiguration), plus a general overhaul of the page. Not intended to be comprehensive.
Deletions are marked like this. Additions are marked like this.
Line 2: Line 2:
'''DRM, Graphics & X11 (Xorg)''' '''DRM, graphics and X11 (X.Org)'''
Line 5: Line 5:
This page and all the linked articles presents the status and directions of all the low-level components making FreeBSD usable as a desktop.

This '''includes''':
This page and linked articles present the status and directions of '''low-level''' components with which FreeBSD becomes a basis for desktop environments (DEs) such as [[ KDE | KDE Plasma ]] and [[Gnome]].

This level includes:
Line 16: Line 16:
It does not include:
 * [[Gnome]], [[KDE]] or any other integrated desktop environments
 * Image processing or drawing software applications
This level does not include:
 * The DEs
 * Image processing or drawing software applications.
Line 25: Line 25:

Line 75: Line 73:

=== Intel Integrated Graphics (aka HD Graphics) ===

Intel HD Graphics refers to the class of graphics chips that are integrated on the same die as an Intel CPU. [[ https://en.wikipedia.org/wiki/Intel_Graphics_Technology|This ]] Wikipedia entry provides a good overview of the various variations and names used for generations of Intel HD Graphics. You will find Intel HD Graphics chips on many modern laptop and desktop systems that ship with an Intel processor. As far as FreeBSD goes, and starting with 12.0-RELEASE, one should use the drm-kmod port.

It is supplied as a port, and provide a kernel module to enable the integrated graphics chip on Intel CPUs. Generally speaking if you have a system with one of these graphics adapters it is suggested to install the `drm-kmod` metaport, which should work well on all systems. This code is under active development and allows us to track more closely the drivers present in the Linux kernel.

[[Graphics/Intel-GPU-Matrix|This page]] contains a table should illustrate the state of various Intel chipsets.

Furthermore, if you notice high CPU usage or excessive tearing while viewing HD video it is reported that installing the `libva-intel-driver` is helpful, as it enables VAAPI support on these systems. This package should be installed in addition to the `drm-kmod`, `mesa-libs` and `mesa-dri` packages.

==== Example Configuration For Intel system ====

A common configuration is a user who has an Intel laptop with a Kabylake Intel i915 HD Graphics chip. To enable the chipset one would follow these instructions:

 * Install the [[ https://www.freshports.org/graphics/drm-kmod/|drm-kmod ]] package
    `$ sudo pkg install drm-kmod`

 * Take note of the post-install package message from drm-''fbsd<version>''-kmod as it contains important information - specifically add this to your /etc/rc.conf or /etc/rc.conf.d/intel file:
    `kld_list="/boot/modules/i915kms.ko"`

 * Ensure your UID is a member of the "video" group.

 * Restart your system; you should see the i915kms.ko get loaded and a flash on your console as we switch over to the new display driver.

 * Start Xorg via your usual method (i.e. startx, GDM, etc.)
    

'''Note:''' For systems that are able to take advantage of this updated DRM code you do not need to prepare an xorg.conf configuration file, and installing the xf86-video-intel port is optional. Our Xorg should autodetect the driver, and utilize the [[ https://www.x.org/wiki/ModeSetting/|modesetting ]] Xorg driver and [[ https://www.freedesktop.org/wiki/Software/Glamor/| glamor ]] driver.

=== AMD Graphics ===

AMD based GPUs are also supported using the drm-kmod port or package. Unlike the i915 Intel graphics driver there are two separate modules available for AMD devices based on their generation. The modules are named:
=== drm-kmod ===

[[ https://www.freshports.org/graphics/drm-kmod/ | graphics/drm-kmod ]] indirectly provides a range of kernel modules for use with Intel Integrated Graphics and AMD graphics hardware.

Associated code is actively developed and allows us to track, more closely, drivers in the Linux kernel.

==== Intel Integrated Graphics (aka HD Graphics) ====

Intel HD Graphics refers to the class of graphics chips that are integrated on the same die as an Intel CPU. Wikipedia offers [[ https://en.wikipedia.org/wiki/Intel_Graphics_Technology | a good overview of the variations and names used for generations of Intel HD Graphics ]]. Intel HD Graphics chips are found in many modern laptop and desktop systems that ship with an Intel CPU. Commonly-found configurations include Kabylake Intel i915 HD Graphics.

To enable the integrated graphics chip on Intel CPUs, install drm-kmod. The resulting module should work well on all compatible systems.

[[Graphics/Intel-GPU-Matrix|This page]] includes a table of states for various Intel chipsets.

If you notice high CPU usage, or excessive tearing with HD video: [[ https://www.freshports.org/multimedia/libva-intel-driver/ | multimedia/libva-intel-driver ]] may help – installation should be in addition to `drm-kmod`, `mesa-libs` and `mesa-dri`.

Example configuration:

 * Install the graphics/drm-kmod package
    # `pkg install drm-kmod`

 * The post-installation message presents essential information. With FreeBSD 13⋯, this command will safely configure your `/etc/rc.conf`:
    # `sysrc -f /etc/rc.conf kld_list+=" i915kms"`

 * Ensure that your UID is a member of the `video` group.

 * Restart your system. You should see `i915kms` listed, and a flash of the console when the display driver is switched.

 * Start X.Org via your usual method (i.e. startx, GDM, etc.)

In most cases:

 * Manual configuration of X.Org is not required

 * [[https://www.freshports.org/x11-drivers/xf86-video-intel/ | x11-drivers/xf86-video-intel]] is optional

– X.Org should autodetect the driver, and utilize the [[ https://www.x.org/wiki/ModeSetting/|modesetting ]] X.Org driver and [[ https://www.freedesktop.org/wiki/Software/Glamor/| glamor ]] driver.

==== AMD Graphics ====

Unlike the i915 Intel graphics driver, two modules exist for AMD hardware:
Line 111: Line 117:
To view the AMD graphics support matrix view [[Graphics/AMD-GPU-Matrix|this page]]. The Xorg project also has a great resource on decoding AMD marketing names to engineering friendly names [[https://www.x.org/wiki/RadeonFeature/#index5h2|here]].

It is important to note that there is currently a conflict with both AMD drivers and the EFI frame buffer. The current workaround, when booting via UEFI on these systems, is to disable the frame buffer via /boot/loader.conf:

`hw.syscons.disable=1`

This will have the side effect of there being no console output until either the amdgpu or radeonkms kernel driver is loaded. Please see [[ https://github.com/FreeBSDDesktop/DEPRECATED-freebsd-base-graphics/issues/170|this ]] Github issue for more context.


==== AMD GPU ====

AMD GPU is the kernel module that can be used to support post-HD7000 or Tahiti GPUs. To enable graphics on these systems you would do the following:

 * Install the [[ https://www.freshports.org/graphics/drm-kmod/|drm-kmod ]] package
    `$ sudo pkg install drm-kmod`

 * Take note of the post-install package message from drm-''fbsd<version>''-kmod as it contains important information - specifically add this to your /etc/rc.conf or /etc/rc.conf.d/amd file:
    `kld_list="/boot/modules/amdgpu.ko"`

 * Ensure that your UID is a member of the "video" group.

 * Restart your system; you should see the amdgpu.ko get loaded and a flash on your console as we switch over to the new display driver.

 * Start Xorg via your usual method (i.e. startx, GDM, etc.)

==== Radeon KMS ====

Radeon KMS is a distinct driver intended for older AMD based GPUs that are available in pre-HD7000 or Tahiti GPUs. To enable graphics on systems with these GPUs you would do the following:

 * Install the [[ https://www.freshports.org/graphics/drm-kmod/|drm-kmod ]] package
    `$ sudo pkg install drm-kmod`

 * Take note of the post-install package message from drm-''fbsd<version>''-kmod as it contains important information - specifically add this to your /etc/rc.conf or /etc/rc.conf.d/radeon file:
    `kld_list="/boot/modules/radeonkms.ko"`

 * Ensure that your UID is a member of the "video" group.

 * Restart your system; you should see the radeonkms.ko get loaded and a flash on your console as we switch over to the new display driver.

 * Start Xorg via your usual method (i.e. startx, GDM, etc.)
– choose '''one''', based on the generation of the hardware.

In most cases:

 * Manual configuration of X.Org is not required.

We have an [[ Graphics/AMD-GPU-Matrix | AMD graphics support matrix ]]. The X.Org project provides a [[ https://www.x.org/wiki/RadeonFeature/#index5h2 | Decoder ring for engineering vs marketing names]].

If UEFI boot results in a conflict between a driver and the EFI frame buffer, you can add this line to `/boot/loader.conf` to disable the buffer:

    `hw.syscons.disable=1`

With the buffer disabled, console output will not appear until the driver loads. https://github.com/FreeBSDDesktop/DEPRECATED-freebsd-base-graphics/issues/170 explains.

===== AMD GPU =====

The amdgpu module is for post-HD7000 or Tahiti GPUs.

 * Install the graphics/drm-kmod package
    # `pkg install drm-kmod`

 * The post-installation message presents essential information. With FreeBSD 13⋯, this command will safely configure your `/etc/rc.conf`:
    # `sysrc -f /etc/rc.conf kld_list+=" amdgpu"`

 * Ensure that your UID is a member of the `video` group.

 * Restart your system. You should see `amdgpu` listed, and a flash of the console when the display driver is switched.

 * Start X.Org via your usual method (i.e. startx, GDM, etc.)

===== Radeon KMS (kernel mode setting) =====

The radeonkms module is for older GPUs (pre-HD7000 or pre-Tahiti).

 * Install the graphics/drm-kmod package
    # `pkg install drm-kmod`

 * The post-installation message presents essential information. With FreeBSD 13⋯, this command will safely configure your `/etc/rc.conf`:
    # `sysrc -f /etc/rc.conf kld_list+=" radeonkms"`

 * Ensure that your UID is a member of the `video` group.

 * Restart your system. You should see `radeonkms` listed, and a flash of the console when the display driver is switched.

 * Start X.Org via your usual method (i.e. startx, GDM, etc.)
Line 155: Line 166:
Experimental support for accelerated graphics in FreeBSD as guest OS in VMware was added to drm-devel-kmod.

Known bugs:
 * There is a known race condition where the machine can lock up when loading the graphics driver or starting X. So far this has only been observed when the guest is configured with more than 1 CPU.
Experimental support for accelerated graphics in FreeBSD as guest OS in VMware was added to [[ https://www.freshports.org/graphics/drm-devel-kmod/ | graphics/drm-devel-kmod ]].

Known issue:
 * A race condition in which the machine locks when loading the graphics driver or starting X. Observable only if the guest is configured with more than one CPU.
Line 161: Line 172:
A DRM driver for VirtualBox is going to be added to the Linux source tree in the next coming minor versions. Once it's there, a FreeBSD port is planned. A DRM driver for VirtualBox is planned for the Linux source tree. Once there, a FreeBSD port is planned.

DRM, graphics and X11 (X.Org)

Introduction

This page and linked articles present the status and directions of low-level components with which FreeBSD becomes a basis for desktop environments (DEs) such as KDE Plasma and Gnome.

This level includes:

  • X.Org-related ports: xserver, libraries, tools
  • Future Wayland-related ports
  • Mesa ports: libGL, dri, libglesv2, libEGL, freeglut, libGLU, libGLw, mesa-demos, libosmesa
  • OpenCL low-level libraries
  • Userland drivers (ie. xf86-*)

  • Input devices detection and configuration
  • Kernel-side GPU drivers (i.e. drm-* kernel modules)

This level does not include:

  • The DEs
  • Image processing or drawing software applications.


Other pages in this namespace:

Development

Developer information, including tasks in progress and similar, is available in the developer section.

TODO

Tasks available to contributers

Task

Developer

Status

Comment

Get Intel GPU Tools working

Initial port exists

Outdated initial port here

Team Members

who

area of responsibility/knowledge

zeising@

Everything ports related, team meetings, etc.

manu@

mesa, drm drivers

bapt@

ports, a bit of everything

imp@

core liason, contact him before committing maintainer timeouts

jkim@

ports, member emeritus

kwm@

ports, member emeritus

miwi@

ports, member emeritus

Contact

Hardware Support

The tables below are not an exhaustive list of supported hardware. Hardware is only listed if and when it has been explicitly tested/confirmed by developers and/or users. Graphics hardware missing from these tables may or may not work. If you have tested hardware that is not on the list, please report the results.

About GPU codenames vs. marketing names

The entries below are misleading because they use the marketing names as the "key". This table needs to be rewritten using GPU codenames as the key.

If your GPU is not supported

If your GPU is not supported by FreeBSD, you can fallback to VESA (if your computer uses a BIOS) or SCFB (if your computer uses UEFI). For the latter case, you can find instructions to setup SCFB in a dedicated article.

drm-kmod

graphics/drm-kmod indirectly provides a range of kernel modules for use with Intel Integrated Graphics and AMD graphics hardware.

Associated code is actively developed and allows us to track, more closely, drivers in the Linux kernel.

Intel Integrated Graphics (aka HD Graphics)

Intel HD Graphics refers to the class of graphics chips that are integrated on the same die as an Intel CPU. Wikipedia offers a good overview of the variations and names used for generations of Intel HD Graphics. Intel HD Graphics chips are found in many modern laptop and desktop systems that ship with an Intel CPU. Commonly-found configurations include Kabylake Intel i915 HD Graphics.

To enable the integrated graphics chip on Intel CPUs, install drm-kmod. The resulting module should work well on all compatible systems.

This page includes a table of states for various Intel chipsets.

If you notice high CPU usage, or excessive tearing with HD video: multimedia/libva-intel-driver may help – installation should be in addition to drm-kmod, mesa-libs and mesa-dri.

Example configuration:

  • Install the graphics/drm-kmod package
    • # pkg install drm-kmod

  • The post-installation message presents essential information. With FreeBSD 13⋯, this command will safely configure your /etc/rc.conf:

    • # sysrc -f /etc/rc.conf kld_list+=" i915kms"

  • Ensure that your UID is a member of the video group.

  • Restart your system. You should see i915kms listed, and a flash of the console when the display driver is switched.

  • Start X.Org via your usual method (i.e. startx, GDM, etc.)

In most cases:

– X.Org should autodetect the driver, and utilize the modesetting X.Org driver and glamor driver.

AMD Graphics

Unlike the i915 Intel graphics driver, two modules exist for AMD hardware:

  • amdgpu
  • radeonkms

– choose one, based on the generation of the hardware.

In most cases:

  • Manual configuration of X.Org is not required.

We have an AMD graphics support matrix. The X.Org project provides a Decoder ring for engineering vs marketing names.

If UEFI boot results in a conflict between a driver and the EFI frame buffer, you can add this line to /boot/loader.conf to disable the buffer:

  • hw.syscons.disable=1

With the buffer disabled, console output will not appear until the driver loads. https://github.com/FreeBSDDesktop/DEPRECATED-freebsd-base-graphics/issues/170 explains.

AMD GPU

The amdgpu module is for post-HD7000 or Tahiti GPUs.

  • Install the graphics/drm-kmod package
    • # pkg install drm-kmod

  • The post-installation message presents essential information. With FreeBSD 13⋯, this command will safely configure your /etc/rc.conf:

    • # sysrc -f /etc/rc.conf kld_list+=" amdgpu"

  • Ensure that your UID is a member of the video group.

  • Restart your system. You should see amdgpu listed, and a flash of the console when the display driver is switched.

  • Start X.Org via your usual method (i.e. startx, GDM, etc.)

Radeon KMS (kernel mode setting)

The radeonkms module is for older GPUs (pre-HD7000 or pre-Tahiti).

  • Install the graphics/drm-kmod package
    • # pkg install drm-kmod

  • The post-installation message presents essential information. With FreeBSD 13⋯, this command will safely configure your /etc/rc.conf:

    • # sysrc -f /etc/rc.conf kld_list+=" radeonkms"

  • Ensure that your UID is a member of the video group.

  • Restart your system. You should see radeonkms listed, and a flash of the console when the display driver is switched.

  • Start X.Org via your usual method (i.e. startx, GDM, etc.)

Virtual Machines

VMware

Experimental support for accelerated graphics in FreeBSD as guest OS in VMware was added to graphics/drm-devel-kmod.

Known issue:

  • A race condition in which the machine locks when loading the graphics driver or starting X. Observable only if the guest is configured with more than one CPU.

VirtualBox

A DRM driver for VirtualBox is planned for the Linux source tree. Once there, a FreeBSD port is planned.

Reporting

Issues / Bugs

If encountering problems in either the kernel driver or the in-development ports, post the following information to the mailing list

  • dmesg command output

  • pciconf -lvbce command output

  • devinfo -vr command output

  • sysctl hw.model

  • pkg info command output

  • Contents of xorg.conf file (and included sub-files, if any)

  • Contents of Xorg.log (if the problem is at X.Org startup or during your X session)
  • Any ports build or installation errors (if relevant)
  • If a kernel panic: Contents of core.$n.txt (in /var/crash)

  • Any other details that may be relevant

Debugging Tips

  • It is useful to see what features the kernel reports as being available, especially in regards to driver features exposed via the linuxkpi. On FreeBSD these are mapped to sysctl compat.linuxkpi. The best way to see what's available for your driver is to execute sysctl compat.linuxkpi after you loaded the driver. For description of what these parameters do, call sysctl with the description flag.
    • % sysctl -d compat.linuxkpi.enable_fbc

      compat.linuxkpi.enable_fbc: Enable frame buffer compression for power savings (default: -1 (use per-chip default))

  • Starting with FreeBSD 13 you can use the direct driver sysctls, the compat.linuxkpi will be removed at one point.
    • % sysctl -d hw.i915kms

  • Periodically you will have a kernel panic but a core will not be recorded. You can test setting this sysctl knob which will prevent you from entering ddb on panic which has been found to unreliable in some circumstances:
    • debug.debugger_on_panic=0

  • Also, adding this to your /boot/loader.conf can help in these scenarios:
    • dev.drm.skip_ddb="1"

  • The following can be useful for providing context and can be set in /boot/loader.conf to ensure debug output remains enabled. The one problem with it is that debug output will slow things down enough to mask many problems.:
    • dev.drm.drm_debug_persist="1"

  • Want to enable all DRM related debug flags at runtime? There is a knob for that:
    • dev.drm.drm_debug=-1

  • kms drivers through linux-kpi report debugging information using debugfs. To mount it:
    • # mkdir /debug && mount -t debugfs none /debug

  • To test how hardware acceleration is working you may want to run glxgears, but by default it may force syncing with your display (60fps for example). To disable this you can invoke glxgears like so:

    • $ env vblank_mode=0 glxgears

Test Results

If everything works, let us know on the mailing list. Your information helps us confirm which hardware/software configurations work well.

Please include:

  • dmesg command output

  • pciconf -lvbce command output

  • pkg info command output

  • Contents of xorg.conf file (and included sub-files, if any)

  • Contents of Xorg.log
  • Any other details that may be relevant

If your laptop works well with FreeBSD, add it to the Laptops page.

Known Issues

  • Permission errors, or inability to start X when using the DRM kernel modules? Make sure your user is a member of the video group, otherwise you will not have access to /dev/drm/ devices.

  • Xorg -configure crashes with a "Segmentation fault"; it is a known defect. Do not use Xorg -configure anymore: it is recommended to let Xorg auto-configure itself. If you need to override part of the configuration, create a config file under /usr/local/etc/X11/xorg.conf.d/ containing only the relevant section.

  • There are reports that users on i386 hardware have problems using the drm-kmod package. A workaround for this is to disable PAE via /boot/loader.conf: hw.above4g_allow=0

Wayland

Wayland has its own page.

OpenCL

OpenCL has its own page.

Legacy Documentation

There is a copy of the previous iteration of this page available here. Hopefully no critical information was left out during this migration, but please notify the team if anything was missed!

Meeting Notes

Here's a handy link to the last couple of Graphics Team meetings:

July 12, 2021

Preferred Policies on Patches

In the past, the FreeBSD graphics stack got far behind the upstream sources. One of the main reasons for this was that as a project we'd been terrible about getting changes accepted upstream (or even trying to upstream them). These technical issues lead to much frustration and exacerbated many teamwork issues with the stack. For a time, things were somewhat dysfunctional. However, the graphics teams has caught up on all this technical debt by upstreaming changes; integrating Linux compatible APIs (like evdev); or by writing adapters to make FreeBSD-specific things like devd look like their Linux counterparts.

To avoid a repeat of this accumulation of technical debt, and all the issues that go with it, the graphics teams has a number of preferred practices it likes to follow. Generally we prefer using released versions of the elements of FreeBSD graphics stack. Issues come up between releases, and if the patches are accepted by upstream, then we'll include them. When there are issues that are being sorted out upstream, we prefer to let that run its course because they are usually the experts, though exceptions are made when reasonable. At the very least, we'd like any patches submitted upstream before they are included in a port to strongly encouraging upstreaming. Finally, when new features are implemented, there's a strong preference for using Linux and other APIs upstream sources are using over inventing something new for FreeBSD where possible.

We also desire to have FreeBSD be in the CI process for as many upstream sources as possible, though currently many do not yet have FreeBSD CI support. Helping upstreams get better CI integration will help us maintain the velocity of releases as FreeBSD is more likely to work and needs less regression testing on updates by us.


CategoryProject CategoryTeam CategoryPorts

Graphics (last edited 2024-04-29T06:18:15+0000 by AlexanderVereeken)